63 lines
2.3 KiB
Nix
63 lines
2.3 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ config, lib, pkgs, modulesPath, ... }:
|
||
|
||
{
|
||
system.stateVersion = "23.11";
|
||
networking.hostName = "nussbaum";
|
||
|
||
imports =
|
||
[ (modulesPath + "/installer/scan/not-detected.nix")
|
||
# ../defaults/fonts.nix
|
||
];
|
||
|
||
# Use the systemd-boot EFI boot loader.
|
||
boot.loader.systemd-boot.enable = true;
|
||
boot.loader.efi.canTouchEfiVariables = true;
|
||
|
||
boot.initrd.availableKernelModules = [ "xhci_pci" "nvme" "usb_storage" "sd_mod" "sdhci_pci" ];
|
||
boot.initrd.kernelModules = [ ];
|
||
boot.kernelModules = [ "kvm-intel" ];
|
||
boot.extraModulePackages = [ ];
|
||
|
||
|
||
boot.initrd.luks.devices."nussbaum".device = "/dev/disk/by-uuid/683a959d-f887-4fe9-9a5c-8c65e39c0647";
|
||
boot.initrd.luks.devices."swap".device = "/dev/disk/by-uuid/f3dde71d-e12d-487e-81e8-7905d679aebb"; #used to be enabled
|
||
|
||
fileSystems."/boot" =
|
||
{ device = "/dev/disk/by-uuid/2279-E1C9";
|
||
fsType = "vfat";
|
||
};
|
||
|
||
fileSystems."/" =
|
||
{ device = "/dev/disk/by-uuid/6a60a9f9-47d6-4617-a1cd-99cdc5a0f550";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
swapDevices =
|
||
[ { device = "/dev/disk/by-uuid/1df5f3df-8d38-41df-aac4-999747e5feab"; }
|
||
];
|
||
|
||
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
|
||
|
||
# services.thinkfan.enable = true;
|
||
boot.extraModprobeConfig = ''
|
||
options thinkpad_acpi fan_control=1
|
||
'';
|
||
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
||
# (the default) this is the recommended approach. When using systemd-networkd it's
|
||
# still possible to use this option, but it's recommended to use it in conjunction
|
||
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
|
||
|
||
networking.useDHCP = lib.mkDefault true;
|
||
|
||
# networking.interfaces.enp0s31f6.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.wlp0s20f3.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.wwan0.useDHCP = lib.mkDefault true;
|
||
|
||
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
||
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
||
|
||
nixpkgs.config.allowUnfree = true; ## required by android-studio
|
||
}
|